const regex = /(?<inl>\/\/[^\n]*\r?\n)|(?<mtl>\/\*[^\*]*\*\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<inl>\\\/\\\/[^\\n]*\\r?\\n)|(?<mtl>\\\/\\*[^\\*]*\\*\\\/)', 'gm')
const str = `codecode
//codecode
/*commmze */
/* comentaire
encore
et encore
*/
code cpode
/* com//mentaitree
/* imbrication
// méchant */
ça c'est du com à la con
*/
code code`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}