#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<inl>\/\/[^\n]*\r?\n)|(?<mtl>\/\*[^\*]*\*\/)"
Local $sString = "codecode" & @CRLF & _
"//codecode" & @CRLF & _
"" & @CRLF & _
"/*commmze */" & @CRLF & _
"/* comentaire" & @CRLF & _
"encore" & @CRLF & _
"et encore " & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"code cpode" & @CRLF & _
"" & @CRLF & _
"/* com//mentaitree" & @CRLF & _
"/* imbrication " & @CRLF & _
"// méchant */" & @CRLF & _
"ça c'est du com à la con" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"code code"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")