$re = '/(?<inl>\/\/[^\n]*\r?\n)|(?<mtl>\/\*[^\*]*\*\/)/m';
$str = 'codecode
//codecode
/*commmze */
/* comentaire
encore
et encore
*/
code cpode
/* com//mentaitree
/* imbrication
// méchant */
ça c\'est du com à la con
*/
code code';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);