import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<inl>\\/\\/[^\\n]*\\r?\\n)|(?<mtl>\\/\\*[^\\*]*\\*\\/)";
final String string = "codecode\n"
+ "//codecode\n\n"
+ "/*commmze */\n"
+ "/* comentaire\n"
+ "encore\n"
+ "et encore \n"
+ "*/\n\n"
+ "code cpode\n\n"
+ "/* com//mentaitree\n"
+ "/* imbrication \n"
+ "// méchant */\n"
+ "ça c'est du com à la con\n"
+ "*/\n\n"
+ "code code";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}