re = /(?<inl>\/\/[^\n]*\r?\n)|(?<mtl>\/\*[^\*]*\*\/)/m
str = 'codecode
//codecode
/*commmze */
/* comentaire
encore
et encore
*/
code cpode
/* com//mentaitree
/* imbrication
// méchant */
ça c\'est du com à la con
*/
code code'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end