import Foundation
let pattern = ##"(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
aikh3!kc
aiKH3ckc
aiKHhckc
aiKH33 !kc
aiKH3!kdsc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}