$re = '/(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}/';
$str = 'aikh3!kc
aiKH3ckc
aiKHhckc
aiKH33 !kc
aiKH3!kdsc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);