const regex = /(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*[A-Z])(?=.*[0-9])(?!.\\n)(?!.*\\s)(?=.*[!$#+@%&]).{8,}', '')
const str = `aikh3!kc
aiKH3ckc
aiKHhckc
aiKH33 !kc
aiKH3!kdsc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}