using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}";
string input = @"aikh3!kc
aiKH3ckc
aiKHhckc
aiKH33 !kc
aiKH3!kdsc";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}