#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}"
Local $sString = "aikh3!kc" & @CRLF & _
"aiKH3ckc" & @CRLF & _
"aiKHhckc" & @CRLF & _
"aiKH33 !kc" & @CRLF & _
"aiKH3!kdsc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")