import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[A-Z])(?=.*[0-9])(?!.\\n)(?!.*\\s)(?=.*[!$#+@%&]).{8,}";
final String string = "aikh3!kc\n"
+ "aiKH3ckc\n"
+ "aiKHhckc\n"
+ "aiKH33 !kc\n"
+ "aiKH3!kdsc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}