import Foundation
let pattern = #"<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class="outer">
<h1>SomeHeader</h1>
<div id="target">
<h2>anotherHeader</h2>
<div id="child">
<div id="grand-child">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)