import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div id=\"\"target\"\"((?'nested'<div)|</div(?'-nested')|[\\w\\W]*?)*</div>";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ " <head>\n"
+ " <title>someTitle</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <div class=\"outer\">\n"
+ " <h1>SomeHeader</h1>\n"
+ " <div id=\"target\">\n"
+ " <h2>anotherHeader</h2>\n"
+ " <div id=\"child\">\n"
+ " <div id=\"grand-child\">\n"
+ " <h4>HelloWorld</h4>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}