re = /<div id=""target""((?'nested'<div)|<\/div(?'-nested')|[\w\W]*?)*<\/div>/m
str = '<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class="outer">
<h1>SomeHeader</h1>
<div id="target">
<h2>anotherHeader</h2>
<div id="child">
<div id="grand-child">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end