# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div id=\"\"target\"\"((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>"
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
" <head>\n"
" <title>someTitle</title>\n"
" </head>\n"
" <body>\n"
" <div class=\"outer\">\n"
" <h1>SomeHeader</h1>\n"
" <div id=\"target\">\n"
" <h2>anotherHeader</h2>\n"
" <div id=\"child\">\n"
" <div id=\"grand-child\">\n"
" <h4>HelloWorld</h4>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.