$re = '/<div id=""target""((?\'nested\'<div)|</div(?\'-nested\')|[\w\W]*?)*</div>/m';
$str = '<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class="outer">
<h1>SomeHeader</h1>
<div id="target">
<h2>anotherHeader</h2>
<div id="child">
<div id="grand-child">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);