// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>"#).unwrap();
let string = "<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class=\"outer\">
<h1>SomeHeader</h1>
<div id=\"target\">
<h2>anotherHeader</h2>
<div id=\"child\">
<div id=\"grand-child\">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}