// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\.version\s*=\s*['"]?(.*?)(?:['"]|$)"#).unwrap();
let string = " s.version = \"0.0.0\"
a.version = 'version'
s.version = '0.0.0'
s.version = PACKAGE::VERSION";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}