package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.version\s*=\s*['"]?(.*?)(?:['"]|$)`)
var str = ` s.version = "0.0.0"
a.version = 'version'
s.version = '0.0.0'
s.version = PACKAGE::VERSION`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}