const regex = new RegExp('\\.version\\s*=\\s*[\\'"]?(.*?)(?:[\\'"]|$)', 'gm')
const str = ` s.version = "0.0.0"
a.version = 'version'
s.version = '0.0.0'
s.version = PACKAGE::VERSION`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}