using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.version\s*=\s*['""]?(.*?)(?:['""]|$)";
string input = @" s.version = ""0.0.0""
a.version = 'version'
s.version = '0.0.0'
s.version = PACKAGE::VERSION";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}