$re = '`\.version\s*=\s*[\'"]?(.*?)(?:[\'"]|$)`m';
$str = ' s.version = "0.0.0"
a.version = \'version\'
s.version = \'0.0.0\'
s.version = PACKAGE::VERSION';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);