re = /\.version\s*=\s*['"]?(.*?)(?:['"]|$)/m
str = ' s.version = "0.0.0"
a.version = \'version\'
s.version = \'0.0.0\'
s.version = PACKAGE::VERSION'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end