import Foundation
let pattern = #"^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}