re = /^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)/
str = 'https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582'
# Print the match result
str.match(re) do |match|
puts match.to_s
end