#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)"
Local $sString = "https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582" & @CRLF & _
"" & @CRLF & _
"https://www.innovasport.com/c/p/" & @CRLF & _
"" & @CRLF & _
"https://www.innovasport.com/c/prendas/" & @CRLF & _
"" & @CRLF & _
"https://www.innovasport.com/p/" & @CRLF & _
"" & @CRLF & _
"https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")