package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)`)
var str = `https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}