using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)";
string input = @"https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}