$re = '/^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)/';
$str = 'https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);