import Foundation
let pattern = #"^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds
ERROR: Address 93.184.216.34 has not changed.
ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)