$re = '/^(?\'stat\'[a-zA-Z]*)|(?\'ip\'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?\'desc\'was found on a blacklist|has not changed)|$/m';
$str = 'Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds
ERROR: Address 93.184.216.34 has not changed.
ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);