const regex = /^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'stat\'[a-zA-Z]*)|(?\'ip\'\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})|(?\'desc\'was found on a blacklist|has not changed)|$', 'gm')
const str = `Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds
ERROR: Address 93.184.216.34 has not changed.
ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}