package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$`)
var str = `Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds
ERROR: Address 93.184.216.34 has not changed.
ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}