use strict;
my $str = 'Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds
ERROR: Address 93.184.216.34 has not changed.
ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error';
my $regex = qr/^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}