#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'stat'[a-zA-Z]*)|(?'ip'\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|(?'desc'was found on a blacklist|has not changed)|$"
Local $sString = "Updated ad.ip.lc to 93.184.216.34 in 0.041 seconds" & @CRLF & _
"ERROR: Address 93.184.216.34 has not changed." & @CRLF & _
"ERROR: The IP 98.150.108.228 was found on a blacklist - please contact an administrator if you believe this is in error"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")