import Foundation
let pattern = #"<p>(<i>|<strong>)*<img.*<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p><img class="mceItem_breakpoint" src="></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class="mceItem_breakpoint" src="" /></i></p>
<p><strong><img class="mceItem_breakpoint" src=""></strong></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)