#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>(<i>|<strong>)*<img.*<\/p>"
Local $sString = "<p><img class="mceItem_breakpoint" src="></p>" & @CRLF & _
"<h4>Platzteller</h4>" & @CRLF & _
"<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>" & @CRLF & _
"<p><i><img class="mceItem_breakpoint" src="" /></i></p>" & @CRLF & _
"<p><strong><img class="mceItem_breakpoint" src=""></strong></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")