using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>(<i>|<strong>)*<img.*<\/p>";
string input = @"<p><img class=""mceItem_breakpoint"" src=""></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class=""mceItem_breakpoint"" src="" /></i></p>
<p><strong><img class=""mceItem_breakpoint"" src=""></strong></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}