$re = '/<p>(<i>|<strong>)*<img.*<\/p>/';
$str = '<p><img class="mceItem_breakpoint" src="></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class="mceItem_breakpoint" src="" /></i></p>
<p><strong><img class="mceItem_breakpoint" src=""></strong></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);