package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<p>(<i>|<strong>)*<img.*<\/p>`)
var str = `<p><img class="mceItem_breakpoint" src="></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class="mceItem_breakpoint" src="" /></i></p>
<p><strong><img class="mceItem_breakpoint" src=""></strong></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}