use strict;
my $str = '<p><img class="mceItem_breakpoint" src="></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class="mceItem_breakpoint" src="" /></i></p>
<p><strong><img class="mceItem_breakpoint" src=""></strong></p>';
my $regex = qr/<p>(<i>|<strong>)*<img.*<\/p>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}