// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>").unwrap();
let string = "<td class='diff-addedline'><div>[[<ins class=\\\"diffchange diffchange-inline\\\">File<\\/ins>:<ins class=\\\"diffchange diffchange-inline\\\">Colt3<\\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\\/div><\\/td>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}