$re = '/<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>/';
$str = '<td class=\'diff-addedline\'><div>[[<ins class=\\"diffchange diffchange-inline\\">File<\\/ins>:<ins class=\\"diffchange diffchange-inline\\">Colt3<\\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\\/div><\\/td>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);