use strict;
my $str = '<td class=\'diff-addedline\'><div>[[<ins class=\\"diffchange diffchange-inline\\">File<\\/ins>:<ins class=\\"diffchange diffchange-inline\\">Colt3<\\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\\/div><\\/td>';
my $regex = qr/<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}