const regex = /<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\\w])+\\.(jpg).*td>', '')
const str = `<td class='diff-addedline'><div>[[<ins class=\\"diffchange diffchange-inline\\">File<\\/ins>:<ins class=\\"diffchange diffchange-inline\\">Colt3<\\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\\/div><\\/td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}