import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\\w])+\\.(jpg).*td>";
final String string = "<td class='diff-addedline'><div>[[<ins class=\\\"diffchange diffchange-inline\\\">File<\\/ins>:<ins class=\\\"diffchange diffchange-inline\\\">Colt3<\\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\\/div><\\/td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}