using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>";
string input = @"<td class='diff-addedline'><div>[[<ins class=\""diffchange diffchange-inline\"">File<\/ins>:<ins class=\""diffchange diffchange-inline\"">Colt3<\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\/div><\/td>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}