// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"format\((.*), (.*), "(.*)", (.*)+\)"#).unwrap();
let string = "mformat(ee_stri, sizeof(ee_stri), \" %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} \", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy);
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}