use strict;
my $str = 'mformat(ee_stri, sizeof(ee_stri), " %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} ", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy);
';
my $regex = qr/format\((.*), (.*), "(.*)", (.*)+\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}