$re = '/format\((.*), (.*), "(.*)", (.*)+\)/';
$str = 'mformat(ee_stri, sizeof(ee_stri), " %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} ", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy);
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);